The case of the ghost clock gadget

 
Has been a bit quiet here, but I am back on the blogging trail.
Starting off with a strange case.

A nephew of mine had a new desktop and got Windows 7 home premium on it. All good and nice.

Suddenly he had a problem with the Clock gadget in the windows sidebar. It’s settings seemed to change. After restarting the computer the clock disappeared. When placing it back and configuring the configuration also did not want to work and after a restart it was gone again. Also I saw a “ghost” gadget appearing sometimes and it was staying on top of other screens at times. Drove me crazy for a bit (and drove my nephew even more crazy actually).

So now on how to solve this issue:

It seems the settings are kept in c:\users\some-user-name\appdata\local\microsoft\windows sidebar
Something there probably did not work correctly.

So what I did was to first go into configuration screen. Programs. Turn windows features on or off. Windows Gadget platform. I uninstalled it from there and restarted the computer.

After the restart removed the settings from the directory named above (I moved it away first just to be sure).

After this install the Windows Gadget Platform again in the same way. I added a few gadgets and made some changes in the config and restarted the machine. All working fine.

To be honest I think only removing the ini file from that directory should be enough to fix the problem in stead of removing the whole directory and contents. If you have downloaded and installed gadgets the first method would also remove those files. We did not have those in our case, so it did not matter.

Good luck if you encounter this.

Bob Cornelissen

Comments are closed.